Resolved
This incident has now been resolved.
If you notice any problems with payments, please reach out to our support team via the in-app chat.
Once again, we apologise for any inconvenience this has caused.
Team Kroo
Monitoring
We are observing improvements with some customer payments now being completed, although some payments may still be delayed.
Our teams are continuing to investigate and will provide a further update within the next hour.
Team Kroo
Identified
Kroo Bank is aware of an issue affecting the processing of payments, causing both inbound and outbound payments to be delayed.
Rest assured your funds are safe and our team is working to restore normal operations as quickly as possible.
We will provide a further update within the next hour and we apologise for any inconvenience experienced during this time.
Team Kroo