Delay in showing Direct Debits, Transactions and Interest Payments in App
Resolved

We’re glad to confirm that the issue with reflecting some transactions in-app has now been resolved and regular service has been restored.

We thank you for your patience during this incident and apologise for any inconvenience caused.

If you are still experiencing issues, please reach out to our Customer Support Team by contacting us via our in-app chat or by emailing help@kroo.com.

Thanks,Team Kroo

Thu, Aug 1, 2024, 01:21 PM
(11 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

We’re glad to confirm that the issue with reflecting some transactions in-app has now been resolved and regular service has been restored.

We thank you for your patience during this incident and apologise for any inconvenience caused.

If you are still experiencing issues, please reach out to our Customer Support Team by contacting us via our in-app chat or by emailing help@kroo.com.

Thanks,Team Kroo

Thu, Aug 1, 2024, 01:21 PM

Monitoring

We’re aware there is a delay to direct debits and interest transaction information showing in your app.

This has now been resolved and may take a few hours for these to appear for all customers. Please rest assured that these transactions have gone through.

Payments under review may take longer to complete, and we’re working hard to reduce the delay.

We’d like to thank you for your patience and apologise for any inconvenience caused.

If you are still experiencing issues, please reach out to our Customer Support Team by emailing help@kroo.com or going to our online support portal.

Thu, Aug 1, 2024, 10:29 AM(2 hours earlier)