In-app chats unavailable
Incident Report for Kroo Bank
Resolved
The issue has now been resolved and normal service has been restored.

We thank you for your patience during this incident and apologise for any inconvenience caused.

If you are still experiencing issues, please reach out to our Customer Support Team by emailing help@kroo.com or through our in-app chat.
Posted Oct 18, 2023 - 18:19 BST
Investigating
We are aware of an issue affecting the availability of in-app chats.

We’re currently investigating this issue and are working to restore normal operations as quickly as possible and would encourage customers who need to contact our Customer Support Team to email help@kroo.com.

We apologise for any inconvenience experienced during this incident.

Team Kroo
Posted Oct 18, 2023 - 17:37 BST
This incident affected: 🛟 Customer Support.