Delayed Visibility of Transactions
Incident Report for Kroo Bank
Resolved
The issue has now been resolved and normal service has been restored.

We thank you for your patience during this incident and apologise for any inconvenience caused.

If you are still experiencing issues, please reach out to our Customer Support Team by emailing help@kroo.com.
Posted Nov 08, 2023 - 11:11 GMT
Investigating
Kroo Bank is aware of an issue affecting visibility of transactions and payments within the App. Transactions and payments are unaffected and will continue to process without issue.

Kroo is currently investigating to restore normal operations as quickly as possible.

The next update is due at 11:30 GMT, or earlier if a significant update is available.

We apologise for any inconvenience experienced during this incident.

Team Kroo
Posted Nov 08, 2023 - 10:39 GMT
This incident affected: 💰 Inbound Bank Transfer and 💸 Outbound Bank Transfer.