Card payment refunds incorrectly treated as debits on accounts
Incident Report for Kroo Bank
Resolved
The issue has now been resolved and normal service has been restored. All incorrectly processed card refunds have now been amended.

We thank you for your patience during this incident and apologise for any inconvenience caused.

If you are still experiencing issues or believe you have an incorrect card refund, please reach out to our Customer Support Team by emailing help@kroo.com or through our in-app chat.
Posted Oct 06, 2023 - 11:01 BST
Update
The fix has been implemented for the issue impacting card refunds and normal operations are restored for all new card refunds.

We are still working to remediate any incorrect card refunds that have been previously affected and we expect that impacted refunds will be resolved within the next hour. We will provide a final update when all refunds have been completed.

If you are still experiencing issues with new refunds, please reach out to our Customer Support Team by emailing help@kroo.com or through our in-app chat.
Posted Oct 06, 2023 - 10:24 BST
Monitoring
A fix has been implemented for the issue impacting card refunds and normal operations are restored for all new card refunds.

We are currently working to remediate any incorrect card refunds that have been previously affected. 

The Kroo team continues to monitor the service and the next update will be provided in 30 minutes or earlier if a significant update is available.

If you are still experiencing issues with new refunds, please reach out to our Customer Support Team by emailing help@kroo.com or through our in-app chat.
Posted Oct 06, 2023 - 09:51 BST
Identified
Kroo has identified the cause of the issue impacting card refunds are working to restore normal operations as quickly as possible.

The next update will be provided in 30 minutes or earlier if a significant update is available.

We apologise for any inconvenience experienced during this incident.
 
Team Kroo
Posted Oct 06, 2023 - 09:20 BST
Investigating
Kroo Bank is aware of an issue affecting refunds on card payments, causing refunds to incorrectly affect customer balances.

Kroo is currently investigating this issue and are working to restore normal operations as quickly as possible and we can assure customers that any refund incorrectly applied to an account will be corrected when the issue is resolved.

The next update will be provided in 30 minutes or earlier if a significant update is available.

We apologise for any inconvenience experienced during this incident.

Team Kroo
Posted Oct 06, 2023 - 08:51 BST
This incident affected: 💳 Card Payments.