Delayed Inbound and Outbound Payments
Incident Report for Kroo Bank
Resolved
We have identified and resolved the root cause effecting Inbound and Outbound payments.

We have also resumed processing requests to update customer profile details.

Team Kroo
Posted Dec 01, 2023 - 09:29 GMT
Update
We are continuing to investigate this issue.
Posted Dec 01, 2023 - 08:35 GMT
Investigating
Kroo Bank is aware of an issue affecting the review process for certain Inbound and Outbound payments within the app, causing delayed processing of customer payments.

We are also experiencing delays in processing requests to update customer profile details.

Rest assured your funds are safe and our team is working to restore normal operations as quickly as possible.

If you notice one of your payments is appearing as under review in the app but you haven't received a message from our team, please do not hesitate to contact our customer service team through our app.

If you have received a message from our team with some questions regarding a payment, please provide a response at your earliest convenience.

We apologise for any inconvenience experienced during this time.

Team Kroo
Posted Nov 30, 2023 - 21:24 GMT
This incident affected: 💰 Inbound Bank Transfer, 💸 Outbound Bank Transfer, and 🛟 Customer Support.