Customer Chats Degraded Performance
Incident Report for Kroo Bank
Resolved
We have resolved the issue impacting customer chats and all functionality has been restored. Thank you for your patience during this incident. If you notice any further issues, please reach out to our customer support team via email at help@kroo.com.
Posted Jun 20, 2023 - 10:08 BST
Investigating
We have identified an issue impacting customer chats and our team is currently working to restore functionality. Customers may experience delays in responses to chats due to a technical fault.

We would encourage customers to contact us via email at help@kroo.com and we will provide a further update when the incident is resolved.

We'd like to apologise for any inconvenience this will cause you.
Posted Jun 20, 2023 - 09:24 BST
This incident affected: 🛟 Customer Support.