Delayed Inbound Payments
Incident Report for Kroo Bank
Resolved
This incident has been resolved.
Posted Jul 28, 2023 - 10:32 BST
Monitoring
A fix has been implemented and payments into Kroo are working as normal. We are continuing to monitor the situation.
Posted Jul 28, 2023 - 10:06 BST
Investigating
We’re aware payments into Kroo may be delayed.

Rest assured your funds are safe and our team is working hard to credit payments to your account as soon as possible.

We are sorry for any inconvenience this is causing you.

Team Kroo
Posted Jul 27, 2023 - 21:45 BST
This incident affected: 💰 Inbound Bank Transfer.